[clue] ZFS on Linux?

Quentin Hartman qhartman at gmail.com
Mon Nov 2 15:57:26 MST 2015

Just a quick note on btrfs, as of a recent-ish kernel (current maybe 9
months ago?) I used btrfs in a storage cluster and it worked well UNTIL the
memory pressure got high. It's a real pig when it comes to RAM usage, and
if you get into high memory pressure situations, it will fail spectacular
and awful ways. I personally would not consider it ready for prime time,
but I know some people have a particular need for some of the features it
offers and so have managed to have some success with it by being very
mindful of how they deploy. It's definitely not the "set it and forget"
filesystem most of us are accustomed to.


On Sun, Nov 1, 2015 at 10:18 AM, adam bultman <adamb at glaven.org> wrote:

> On 10/31/2015 08:27 AM, Sean LeBlanc wrote:
> > Anyone doing this? As many of you may or may not know, I dabble in the
> > BSDs from time to time, and one of those more recent outcomes of that
> > dabbling was a FreeNAS server I set up about 2 years ago to support Time
> > Machine for macs as well as content for a Plex server.
> >
> > They give a bit more background on ZFS - I didn't realize that Snoracle
> > took it closed source after acquisition, and that what is commonly
> > called "ZFS" is probably really OpenZFS, and that Snoracle has their own
> > version now, different than what the rest of world calls ZFS.
> > ___________________________
> For a lark (and for legitimate business purposes) I spent some time
> working with ZFS on linux, in it's two forms (more or less).
> My server was a Dell Poweredge R900 (I think?);  quad proc, quad core,
> 128GB of ECC RAM.  Boot drive was 5 or 6 of the built-in drives in a
> RAID5, with 2 SSDs for log and L2ARC.  I also had an 2 port emulex 10G
> NIC in it, too.  I tried multiple different shelves for running ZFS on -
> old Netapp shelves (FC connected DS14s, one with 500G ATA drives,
> another with 300G FC drives) and two SAS connected shelves of 300G SAS
> drives.  (Not all at once,  mind you.)
> With CentOS6 *and* CentOS7, I couldn't get native ZFS to work
> reliably.   I also tried zfsonlinux, and that *also* didn't work
> reliably.  The system would basically crash if I *really* pushed the
> server hard or seemingly if the RAM cache got too full.
> I was getting ready to blame the RAM (but it checked out with memtest86,
> multiple times) or the 10Gb NIC, but when I installed FreeBSD on the
> server and tested some more, it worked *perfectly*, and never once crashed.
> I spent a decent amount of time trying to get ZFS working on linux - but
> to no avail.  Maybe I did something wrong several times in a row, and
> somehow the default FreeBSD setup is idiot proof - or something's wrong
> with my hardware and somehow I never hit the bug/problem running
> FreeBSD.   I have another box I'm going to test with (only 64GB of RAM,
> and 2 Intel X5550 CPUs) once I find the time to put CentOS 7 on it - and
> hopefully it'll work a whole lot better, since I have a large number of
> disk shelves sitting around, waiting to be used.
> --
> Adam
> _______________________________________________
> clue mailing list: clue at cluedenver.org
> For information, account preferences, or to unsubscribe see:
> http://cluedenver.org/mailman/listinfo/clue
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://cluedenver.org/pipermail/clue/attachments/20151102/3ce1bdf6/attachment.html 

More information about the clue mailing list